System Requirements

 

Calypso Continuing Education courses work with most modern web browsers and operation systems.

Our Recommendation: To get the best experience with our website and courses, we strongly recommend using Mozilla Firefox or  Google Chrome. You can download either browser for free using the preceding links.  Apple’s Safari browser also works well. Internet Explorer is supported, though some students have reported display issues when using it. It is recommended that when using Internet Explorer you update to the newest version available.

Calypso Continuing Education courses use Adobe Flash technology. Adobe Flash Player is free to download and install. If you are having problems viewing our courses, check to see that Flash is installed and updated.

Some of the additional educational materials available with our courses are supplied in PDF format. You will need a PDF reader, such as Adobe Acrobat, to view those resources.  Acrobat Reader is free to download and install.

An internet connection of 1Mbps (one megabit per second) or higher is recommended in order to view the Calypso Continuing Education Appraiser and Environmental courses. Slower connections may work, but our courses contain a fair bit of video content and you may be disappointed with the performance.

If you are attempting to view Calypso courses using your Apple product, please see the following for more information: https://appadvice.com/appguides/show/adobe-flash-on-the-ipad

Please NOTE: CALYPSO DOES NOT ENDORSE ANY SPECIFIC APP.  This link is supplied as informational.  Downloading third-party apps is the individual users’ responsibility.

If you are having trouble, we strongly recommend clearing your browser's cache, cookies, and history. 
For more information, see: Why should you clear your web browser's cache?